UnratedNuGetPublished
Elevation of privilege in ASP.NET Core
CVE-2019-1302 · GHSA-xr8f-59pp-rxxh
- Affected
- NuGet microsoft.aspnetcore.spaservices >= 2.2.0, < 2.2.7; >= 2.1.0, < 2.1.13
- Fixed in
- 2.2.72.1.13· Vendor fix available
- Issue
- An elevation of privilege vulnerability exists when a ASP.NET Core web application, created using vulnerable project templates, fails to properly sanitize web requests, aka 'ASP.NET Core Elevation Of Privilege Vulnerability'.
Recommended action: Upgrade to 2.2.7 or 2.1.13 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.