Skip to content

← Public intelligence

NuGet package

microsoft.aspnetcore.mvc.localization

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedNuGetPublished

    Moderate severity vulnerability that affects Microsoft.AspNetCore.Mvc and Microsoft.AspNetCore.Mvc.Core

    CVE-2017-0248 · GHSA-ch6p-4jcm-h8vh

    Affected
    • NuGet microsoft.aspnetcore.mvc.localization >= 1.0.0, < 1.0.4; >= 1.1.0, < 1.1.3
    Fixed in
    1.0.41.1.3· Vendor fix available
    Issue
    Microsoft .NET Framework 2.0, 3.5, 3.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2 and 4.7 allow an attacker to bypass Enhanced Security Usage taggings when they present a certificate that is invalid for a specific use, aka ".NET Security Feature Bypass Vulnerability."

    Recommended action: Upgrade to 1.1.3 or 1.0.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.5NuGetPublished

    ASP.NET Core fails to properly validate web requests

    CVE-2017-0247 · GHSA-6xh7-4v2w-36q6

    Affected
    • NuGet microsoft.aspnetcore.mvc.localization >= 1.0.0, < 1.0.4; >= 1.1.0, < 1.1.3
    Fixed in
    1.0.41.1.3· Vendor fix available
    Issue
    A denial of service vulnerability exists when the ASP.NET Core fails to properly validate web requests. NOTE: Microsoft has not commented on third-party claims that the issue is that the TextEncoder.EncodeCore function in the System.Text.Encodings.Web package in ASP.NET Core Mvc before 1.0.4 and 1.1.x before 1.1.3 allows remote attackers to cause a denial of service by leveraging failure to properly calculate the length of 4-byte characters in the Unicode Non-Character range.

    Recommended action: Upgrade to 1.1.3 or 1.0.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 5.3NuGetPublished

    Moderate severity vulnerability that affects Microsoft.AspNetCore.Mvc

    CVE-2017-0256 · GHSA-j8f4-2w4p-mhjc

    Affected
    • NuGet microsoft.aspnetcore.mvc.localization >= 1.0.0, < 1.0.4; >= 1.1.0, < 1.1.3
    Fixed in
    1.0.41.1.3· Vendor fix available
    Issue
    A spoofing vulnerability exists when the ASP.NET Core fails to properly sanitize web requests.

    Recommended action: Upgrade to 1.1.3 or 1.0.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →