High, CVSS 8.8NuGetPublished
ASP.NET Core allow an elevation of privilege
CVE-2018-0787 · GHSA-365p-96qv-xr7g
- Affected
- NuGet microsoft.aspnetcore.httpoverrides >= 2.0.0, <= 2.0.1
- Fixed in
- 2.0.2· Vendor fix available
- Issue
- ASP.NET Core 1.0. 1.1, and 2.0 allow an elevation of privilege vulnerability due to how web applications that are created from templates validate web requests, aka "ASP.NET Core Elevation Of Privilege Vulnerability".
Recommended action: Upgrade to 2.0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.