Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.
Open advisories
31 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.
Microsoft is releasing this security advisory to provide information about a vulnerability in .NET Core 3.1 and .NET 6.0. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. A denial of service vulnerability exists in ASP.NET Core 3.1 and .NET 6.0 where a malicious client could cause a stack overflow which may result in a denial of service attack when an attacker sends a customized payload that is parsed during model binding. <a name="affected-software"</aAffected software Any .NET 6.0 application running on .NET 6.0.8 or earlier. Any ASP.NET Core 3.1 application running on .NET Core 3.1.28 or earlier. If your application uses the following package versions, ensure you update to the latest version of .NET. <a name="ASP.NET Core 3.1"</a.NET Core 3.1 Package name | Affected version | Patched version ------------ | ---------------- | ------------------------- Microsoft.AspNetCore.App.Runtime.linux-arm|= 3.1.0, <…
Recommended action: Upgrade to 6.0.9 or 3.1.29 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
Microsoft is releasing this security advisory to provide information about a vulnerability in .NET 6.0, .NET 5.0 and .NET Core 3.1. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. A vulnerability exists in .NET 6.0, .NET 5.0 and .NET core 3.1 where a malicious client can can cause a denial of service when HTML forms are parsed. Affected software Any .NET 6.0 application running on .NET 6.0.4 or earlier. Any .NET 5.0 application running .NET 5.0.16 or earlier. Any .NET Core 3.1 application running on .NET Core 3.1.24 or earlier. Affected packages .NET Core 3.1 | Package name | Affected version | Patched version | |---------------------------------------------------|---------------------|---------------| | Microsoft.AspNetCore.App.Runtime.win-x64 | =3.0.0,3.1.24 | 3.1.25 | | Microsoft.AspNetCore.App.Runtime.linux-x64 | =3.0.0,3.1.24 | 3.1.25 | | Microsoft.AspNetCore.App.Runtime.win-x86 | =3.0.0,3.1.24 | 3.1.25 |…
Recommended action: Upgrade to 6.0.5, 5.0.17 or 3.1.25 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
Microsoft is releasing this security advisory to provide information about a vulnerability in .NET 6.0, .NET 5.0 and .NET Core 3.1. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. A vulnerability exists in .NET 6.0, .NET 5.0 and .NET core 3.1 where a malicious client can manipulate cookies and cause a Denial of Service. Affected software Any .NET 6.0 application running on .NET 6.0.4 or earlier. Any .NET 5.0 application running .NET 5.0.16 or earlier. Any .NET Core 3.1 application running on .NET Core 3.1.24 or earlier. Affected packages .NET Core 3.1 | Package name | Affected versions | Patched versions | |---------------------------------------------------|-------------------|------------------| | Microsoft.Owin.Security.Cookies | <4.2.2 | 4.2.2 | | Microsoft.Owin.Security | <4.2.2 | 4.2.2 | | Microsoft.AspNetCore.App.Runtime.win-x64 | =3.0.0,3.1.24 | 3.1.25 | | Microsoft.AspNetCore.App.Runtime.linux-x64 |…
Recommended action: Upgrade to 6.0.5, 5.0.17 or 3.1.25 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
A denial-of-service vulnerability exists in the way Kestrel parses HTTP/2 requests. The security update addresses the vulnerability by fixing the way the Kestrel parses HTTP/2 requests. Users are advised to upgrade.
Recommended action: Upgrade to 5.0.2 or 3.1.11 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
A security feature bypass vulnerability exists in the way Microsoft ASP.NET Core parses encoded cookie names.The ASP.NET Core cookie parser decodes entire cookie strings which could allow a malicious attacker to set a second cookie with the name being percent encoded.The security update addresses the vulnerability by fixing the way the ASP.NET Core cookie parser handles encoded names., aka 'Microsoft ASP.NET Core Security Feature Bypass Vulnerability'.
Recommended action: Upgrade to 3.1.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
A denial of service vulnerability exists when ASP.NET Core improperly handles web requests, aka ASP.NET Core Denial of Service Vulnerability.
Recommended action: Upgrade to 3.1.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.