Skip to content

← Public intelligence

NuGet package

microsoft.aspnetcore.app.runtime.linux-x64

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

32 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5NuGetPublished

    .NET Denial of Service Vulnerability

    CVE-2022-29117 · GHSA-3rq8-h3gj-r5c6

    Affected
    • NuGet microsoft.aspnetcore.app.runtime.linux-x64 >= 3.0.0, <= 3.1.24; >= 5.0.0, <= 5.0.16; >= 6.0.0, <= 6.0.4
    Fixed in
    5.0.173.1.256.0.5· Vendor fix available
    Issue
    Microsoft is releasing this security advisory to provide information about a vulnerability in .NET 6.0, .NET 5.0 and .NET Core 3.1. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. A vulnerability exists in .NET 6.0, .NET 5.0 and .NET core 3.1 where a malicious client can manipulate cookies and cause a Denial of Service. Affected software Any .NET 6.0 application running on .NET 6.0.4 or earlier. Any .NET 5.0 application running .NET 5.0.16 or earlier. Any .NET Core 3.1 application running on .NET Core 3.1.24 or earlier. Affected packages .NET Core 3.1 | Package name | Affected versions | Patched versions | |---------------------------------------------------|-------------------|------------------| | Microsoft.Owin.Security.Cookies | <4.2.2 | 4.2.2 | | Microsoft.Owin.Security | <4.2.2 | 4.2.2 | | Microsoft.AspNetCore.App.Runtime.win-x64 | =3.0.0,3.1.24 | 3.1.25 | | Microsoft.AspNetCore.App.Runtime.linux-x64 |…

    Recommended action: Upgrade to 6.0.5, 5.0.17 or 3.1.25 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.5NuGetPublished

    ASP.NET Core and Visual Studio Denial of Service Vulnerability

    CVE-2021-1723 · GHSA-242j-2gm6-5rwx

    Affected
    • NuGet microsoft.aspnetcore.app.runtime.linux-x64 >= 3.1.0, < 3.1.11; >= 5.0.0, < 5.0.2
    Fixed in
    3.1.115.0.2· Vendor fix available
    Issue
    A denial-of-service vulnerability exists in the way Kestrel parses HTTP/2 requests. The security update addresses the vulnerability by fixing the way the Kestrel parses HTTP/2 requests. Users are advised to upgrade.

    Recommended action: Upgrade to 5.0.2 or 3.1.11 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.5NuGetPublished

    Cookie parsing failure

    CVE-2020-1045 · GHSA-hxrm-9w7p-39cc

    Affected
    • NuGet microsoft.aspnetcore.app.runtime.linux-x64 >= 3.1.0, < 3.1.8
    Fixed in
    3.1.8· Vendor fix available
    Issue
    A security feature bypass vulnerability exists in the way Microsoft ASP.NET Core parses encoded cookie names.The ASP.NET Core cookie parser decodes entire cookie strings which could allow a malicious attacker to set a second cookie with the name being percent encoded.The security update addresses the vulnerability by fixing the way the ASP.NET Core cookie parser handles encoded names., aka 'Microsoft ASP.NET Core Security Feature Bypass Vulnerability'.

    Recommended action: Upgrade to 3.1.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 7.5NuGetPublished

    ASP.NET Core Denial of Service Vulnerability

    CVE-2020-1597 · GHSA-f8qx-mjcq-wfgx

    Affected
    • NuGet microsoft.aspnetcore.app.runtime.linux-x64 >= 3.1.0, < 3.1.7
    Fixed in
    3.1.7· Vendor fix available
    Issue
    A denial of service vulnerability exists when ASP.NET Core improperly handles web requests, aka ASP.NET Core Denial of Service Vulnerability.

    Recommended action: Upgrade to 3.1.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. High, CVSS 7.5NuGetPublished

    ASP.NET Core Denial of Service Vulnerability

    CVE-2020-1161 · GHSA-3cf7-7wq6-8842

    Affected
    • NuGet microsoft.aspnetcore.app.runtime.linux-x64 >= 3.1.0, < 3.1.4
    Fixed in
    3.1.4· Vendor fix available
    Issue
    A denial of service vulnerability exists when ASP.NET Core improperly handles web requests, aka 'ASP.NET Core Denial of Service Vulnerability'.

    Recommended action: Upgrade to 3.1.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. UnratedNuGetPublished

    Remote code execution in ASP.NET Core

    CVE-2020-0603 · GHSA-655q-9gvg-q4cm

    Affected
    • NuGet microsoft.aspnetcore.app.runtime.linux-x64 >= 3.1.0, < 3.1.1
    Fixed in
    3.1.1· Vendor fix available
    Issue
    A remote code execution vulnerability exists in ASP.NET Core software when the software fails to handle objects in memory.An attacker who successfully exploited the vulnerability could run arbitrary code in the context of the current user, aka 'ASP.NET Core Remote Code Execution Vulnerability'.

    Recommended action: Upgrade to 3.1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  7. UnratedNuGetPublished

    Denial of service in ASP.NET Core

    CVE-2020-0602 · GHSA-23cv-jh4v-vffm

    Affected
    • NuGet microsoft.aspnetcore.app.runtime.linux-x64 >= 3.1.0, < 3.1.1
    Fixed in
    3.1.1· Vendor fix available
    Issue
    A denial of service vulnerability exists when ASP.NET Core improperly handles web requests, aka 'ASP.NET Core Denial of Service Vulnerability'.

    Recommended action: Upgrade to 3.1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →