High, CVSS 7.5NuGetPublished
ASP.NET Core and Visual Studio Denial of Service Vulnerability
CVE-2021-1723 · GHSA-242j-2gm6-5rwx
- Affected
- NuGet microsoft.aspnetcore.app.runtime.linux-musl-arm >= 5.0.1, <= 5.0.1
- Fixed in
- 5.0.2· Vendor fix available
- Issue
- A denial-of-service vulnerability exists in the way Kestrel parses HTTP/2 requests. The security update addresses the vulnerability by fixing the way the Kestrel parses HTTP/2 requests. Users are advised to upgrade.
Recommended action: Upgrade to 5.0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.