Critical, CVSS 9.8NuGetPublished
Improper Input Validation in IpMatcher
CVE-2021-33318 · GHSA-qj93-37f5-mr29
- Affected
- NuGet ipmatcher <= 1.0.4.1
- Fixed in
- 1.0.4.2· Vendor fix available
- Issue
- An Input Validation Vulnerability exists in Joel Christner .NET C packages WatsonWebserver, IpMatcher 1.0.4.1 and below (IpMatcher) and 4.1.3 and below (WatsonWebserver) due to insufficient validation of input IP addresses and netmasks against the internal Matcher list of IP addresses and subnets.
Recommended action: Upgrade to 1.0.4.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.