High, CVSS 7.5NuGetPublished
Improper Authentication in Auth0.AuthenticationApi
CVE-2019-16929 · GHSA-c9cg-q8r2-xvjq
- Affected
- NuGet auth0.authenticationapi >= 5.8.0, < 6.5.4
- Fixed in
- 6.5.4· Vendor fix available
- Issue
- Auth0 auth0.net before 6.5.4 has Incorrect Access Control because IdentityTokenValidator can be accidentally used to validate untrusted ID tokens.
Recommended action: Upgrade to 6.5.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.