UnratedNuGetPublished
Remote code execution vulnerability in dependency System.Drawing.Common
GHSA-gpv5-rp6w-58r8
- Affected
- NuGet akka < 1.4.46; >= 1.5.0-alpha1, < 1.5.0-alpha3
- Fixed in
- 1.4.461.5.0-alpha3· Vendor fix available
- Issue
- Impact The core Akka module depended on an old System.Configuration.ConfigurationManager version 4.7.0 which transitively depends on System.Common.Drawing v4.7.0. The System.Common.Drawing v4.7.0 is affected by a remote code execution vulnerability https://github.com/advisories/GHSA-ghhp-997w-qr28. The real-world impact of this should be low, but users should be advised to upgrade to later versions of Akka.NET. Patches Has the problem been patched? What versions should users upgrade to? This issue is resolved in Akka.NET v1.4.46 and Akka.NET v1.5.0-alpha3. Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? You might be able to explicitly reference System.Configuration.ConfigurationManager's NuGet package and upgrade to 6.0.1 or later without upgrading Akka.NET, but it's probably best to upgrade Akka.NET itself. References Are there any links users can visit to find out more? Original issue: https://github.com/akkadotnet/akka.net/issues/6226…
Recommended action: Upgrade to 1.5.0-alpha3 (pre-release) or 1.4.46 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.