Medium, CVSS 6.1MavenPublished
Jenkins Delivery Pipeline Plugin Cross-site Scripting vulnerability
CVE-2017-1000404 · GHSA-g364-c7w5-93wh
- Affected
- Maven se.diabol.jenkins.pipeline:delivery-pipeline-plugin <= 1.0.7
- Fixed in
- 1.0.8· Vendor fix available
- Issue
- The Jenkins Delivery Pipeline Plugin version 1.0.7 and earlier used the unescaped content of the query parameter 'fullscreen' in its JavaScript, resulting in a cross-site scripting vulnerability through specially crafted URLs. Version 1.0.8 of the plugin converts the value to a boolean (true/false) and inserts that into the page instead.
Recommended action: Upgrade to 1.0.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.