Critical, CVSS 9.3MavenPublished
hermes-management is vulnerable to RCE due to Apache commons-jxpath
GHSA-2gh6-wc3m-g37f
- Affected
- Maven pl.allegro.tech.hermes:hermes-management >= 0.8.2, < 2.2.9
- Fixed in
- 2.2.9· Vendor fix available
- Issue
- Impact hermes-management is vulnerable to RCE when it processes user-controlled data due to using Apache commons-jxpath. Patches Upgrade Hermes to at least hermes-2.2.9 References https://hackinglab.cz/en/blog/remote-code-execution-in-jxpath-library-cve-2022-41852/
Recommended action: Upgrade to 2.2.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.