Skip to content

← Public intelligence

Maven package

org.yaml:snakeyaml

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

7 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.3MavenPublished

    SnakeYaml Constructor Deserialization Remote Code Execution

    CVE-2022-1471 · GHSA-mjmj-j48q-9wg2

    Affected
    • Maven org.yaml:snakeyaml <= 1.33
    Fixed in
    2.0· Vendor fix available
    Issue
    SnakeYaml's Constructor class, which inherits from SafeConstructor, allows any type be deserialized given the following line: new Yaml(new Constructor(TestDataClass.class)).load(yamlContent); Types do not have to match the types of properties in the target class. A ConstructorException is thrown, but only after a malicious payload is deserialized. Severity High, lack of type checks during deserialization allows remote code execution. Proof of Concept Execute bash run.sh. The PoC uses Constructor to deserialize a payload for RCE. RCE is demonstrated by using a payload which performs a http request to http://127.0.0.1:8000. Example output of successful run of proof of concept: Further Analysis Potential mitigations include, leveraging SnakeYaml's SafeConstructor while parsing untrusted content. See https://bitbucket.org/snakeyaml/snakeyaml/issues/561/cve-2022-1471-vulnerability-in#comment-64581479 for discussion on the subject. Timeline Date reported: 4/11/2022 Date fixed:…

    Recommended action: Upgrade to 2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.5MavenPublished

    Snakeyaml vulnerable to Stack overflow leading to denial of service

    CVE-2022-41854 · GHSA-w37g-rhq8-7m4j

    Affected
    • Maven org.yaml:snakeyaml < 1.32
    Fixed in
    1.32· Vendor fix available
    Issue
    Those using Snakeyaml to parse untrusted YAML files may be vulnerable to Denial of Service attacks (DOS). If the parser is running on user supplied input, an attacker may supply content that causes the parser to crash by stack overflow. This effect may support a denial of service attack.

    Recommended action: Upgrade to 1.32 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 5.5MavenPublished

    snakeYAML before 1.31 vulnerable to Denial of Service due to Out-of-bounds Write

    CVE-2022-38750 · GHSA-hhhw-99gj-p3c3

    Affected
    • Maven org.yaml:snakeyaml < 1.31
    Fixed in
    1.31· Vendor fix available
    Issue
    Using snakeYAML to parse untrusted YAML files may be vulnerable to Denial of Service attacks (DOS). If the parser is running on user supplied input, an attacker may supply content that causes the parser to crash by stackoverflow.

    Recommended action: Upgrade to 1.31 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 6.5MavenPublished

    snakeYAML before 1.32 vulnerable to Denial of Service due to Out-of-bounds Write

    CVE-2022-38752 · GHSA-9w3m-gqgf-c4p9

    Affected
    • Maven org.yaml:snakeyaml < 1.32
    Fixed in
    1.32· Vendor fix available
    Issue
    Using snakeYAML to parse untrusted YAML files may be vulnerable to Denial of Service attacks (DoS). If the parser is running on user supplied input, an attacker may supply content that causes the parser to crash by stack-overflow.

    Recommended action: Upgrade to 1.32 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Medium, CVSS 6.5MavenPublished

    snakeYAML before 1.31 vulnerable to Denial of Service due to Out-of-bounds Write

    CVE-2022-38751 · GHSA-98wm-3w3q-mw94

    Affected
    • Maven org.yaml:snakeyaml < 1.31
    Fixed in
    1.31· Vendor fix available
    Issue
    Using snakeYAML to parse untrusted YAML files may be vulnerable to Denial of Service attacks (DOS). If the parser is running on user supplied input, an attacker may supply content that causes the parser to crash by stackoverflow.

    Recommended action: Upgrade to 1.31 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. High, CVSS 7.5MavenPublished

    Uncontrolled Resource Consumption in snakeyaml

    CVE-2022-25857 · GHSA-3mc7-4q67-w48m

    Affected
    • Maven org.yaml:snakeyaml < 1.31
    Fixed in
    1.31· Vendor fix available
    Issue
    The package org.yaml:snakeyaml from 0 and before 1.31 are vulnerable to Denial of Service (DoS) due missing to nested depth limitation for collections.

    Recommended action: Upgrade to 1.31 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  7. High, CVSS 7.5MavenPublished

    SnakeYAML Entity Expansion during load operation

    CVE-2017-18640 · GHSA-rvwf-54qp-4r6v

    Affected
    • Maven org.yaml:snakeyaml < 1.26
    Fixed in
    1.26· Vendor fix available
    Issue
    The Alias feature in SnakeYAML 1.18 allows entity expansion during a load operation, a related issue to CVE-2003-1564.

    Recommended action: Upgrade to 1.26 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →