Critical, CVSS 9.0MavenPublished
XWiki Rendering is vulnerable to XSS attacks through insecure XHTML syntax
CVE-2025-53835 · GHSA-w3wh-g4m9-783p
- Affected
- Maven org.xwiki.rendering:xwiki-rendering-syntax-xhtml >= 5.4.5, < 14.10
- Fixed in
- 14.10· Vendor fix available
- Issue
- Impact The XHTML syntax depended on the xdom+xml/current syntax which allows the creation of raw blocks that permit the insertion of arbitrary HTML content including JavaScript. This allows XSS attacks for users who can edit a document like their user profile (enabled by default). The attack works by setting the document's syntax to xdom+xml/current and then inserting content like This has been fixed by removing the dependency on the xdom+xml/current syntax from the XHTML syntax. Note that the xdom+xml syntax is still vulnerable to this attack. As it's main purpose is testing and its use is quite difficult, this syntax shouldn't be installed or used on a regular wiki. We're currently not aware of any further dependencies on it. Patches The fix of removing the dependency has been included in XWiki 14.10. It is not released for earlier versions due to the potential breakages, among others this change makes it necessary to update the Confluence XHTML syntax as it relies on internals…
Recommended action: Upgrade to 14.10 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.