Critical, CVSS 9.0MavenPublished
org.xwiki.contrib.markdown:syntax-markdown-commonmark12 vulnerable to XSS via Markdown content
CVE-2025-46558 · GHSA-8g2j-rhfh-hq3r
- Affected
- Maven org.xwiki.contrib.markdown:syntax-markdown-commonmark12 >= 8.2, < 8.9
- Fixed in
- 8.9· Vendor fix available
- Issue
- Impact The Markdown syntax is vulnerable to XSS through HTML. In particular, using Markdown syntax, it's possible for any user to embed Javascript code that will then be executed on the browser of any other user visiting either the document or the comment that contains it. In the instance that this code is executed by a user with admins or programming rights, this issue compromises the confidentiality, integrity and availability of the whole XWiki installation. To reproduce, on an instance where the CommonMark Markdown Syntax 1.2 extension is installed, log in as a user without script rights. Edit a document and set its syntax to Markdown. Then , add the content <scriptalert("XSS")</script and refresh the page. If an alert appears containing "XSS", then the instance is vulnerable. Patches This has been patched in version 8.9 of the CommonMark Markdown Syntax 1.2 extension. Workarounds We're not aware of any workaround except upgrading. References…
Recommended action: Upgrade to 8.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.