High, CVSS 7.8MavenPublished
TERASOLUNA Server Framework vulnerable to ClassLoader manipulation
CVE-2022-43484 · GHSA-q5j9-f95w-f4pr
- Affected
- Maven org.terasoluna.gfw:terasoluna-gfw-common < 1.0.1.RELEASE
- Fixed in
- 1.0.1.RELEASE· Vendor fix available
- Issue
- TERASOLUNA Global Framework 1.0.0 (Public review version) and TERASOLUNA Server Framework for Java (Rich) 2.0.0.2 to 2.0.5.1 are vulnerable to ClassLoader manipulation due to using the old version of Spring Framework which contains the vulnerability. The vulnerability is caused by an improper input validation issue in the binding mechanism of Spring MVC. By the application processing a specially crafted file, arbitrary code may be executed with the privileges of the application. When using TERASOLUNA Global Framework 1.0.0 (Public review version), update to TERASOLUNA Server Framework for Java 5.7.1.SP1 (using Spring Framework 5.3.18). This vulnerability alone can be addressed by updating to TERASOLUNA Global Framework 1.0.1 (using Spring Framework 3.2.10) or later.
Recommended action: Upgrade to 1.0.1.RELEASE or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.