Critical, CVSS 9.8MavenPublished
Vulnerability that affects org.springframework.ws:spring-ws and org.springframework.ws:spring-xml
CVE-2019-3773 · GHSA-8222-6fc8-mhvf
- Affected
- Maven org.springframework.ws:spring-ws < 2.4.4; >= 3.0.0, <= 3.0.4
- Fixed in
- 3.0.62.4.4· Vendor fix available
- Issue
- Spring Web Services, versions 2.4.3, 3.0.4, and older unsupported versions of all three projects, were susceptible to XML External Entity Injection (XXE) when receiving XML data from untrusted sources.
Recommended action: Upgrade to 3.0.6 or 2.4.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.