Skip to content

← Public intelligence

Maven package

org.springframework.security:spring-security-core

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

30 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.3MavenPublished

    Insufficiently Protected Credentials and Improper Authentication in Spring Security

    CVE-2019-11272 · GHSA-v33x-prhc-gph5

    Affected
    • Maven org.springframework.security:spring-security-core <= 4.2.12
    Fixed in
    4.2.13· Vendor fix available
    Issue
    Spring Security, versions 4.2.x up to 4.2.12, and older unsupported versions support plain text passwords using PlaintextPasswordEncoder. If an application using an affected version of Spring Security is leveraging PlaintextPasswordEncoder and a user has a null encoded password, a malicious user (or attacker) can authenticate using a password of ?null?.

    Recommended action: Upgrade to 4.2.13 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.3MavenPublished

    Spring Security uses insufficiently random values

    CVE-2019-3795 · GHSA-v2r2-7qm7-jj6v

    Affected
    • Maven org.springframework.security:spring-security-core >= 4.2.0, < 4.2.12; >= 5.0.0, < 5.0.12; >= 5.1.0, < 5.1.5
    Fixed in
    5.1.55.0.124.2.12· Vendor fix available
    Issue
    Spring Security versions 4.2.x prior to 4.2.12, 5.0.x prior to 5.0.12, and 5.1.x prior to 5.1.5 contain an insecure randomness vulnerability when using SecureRandomFactoryBean#setSeed to configure a SecureRandom instance. In order to be impacted, an honest application must provide a seed and make the resulting random material available to an attacker for inspection.

    Recommended action: Upgrade to 5.1.5, 5.0.12 or 4.2.12 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.4MavenPublished

    Spring Security vulnerable to Authorization Bypass

    CVE-2018-15801 · GHSA-27xw-p8v6-9jjr

    Affected
    • Maven org.springframework.security:spring-security-core >= 5.1.0, < 5.1.2
    Fixed in
    5.1.2· Vendor fix available
    Issue
    Spring Security versions 5.1.x prior to 5.1.2 contain an authorization bypass vulnerability during JWT issuer validation. In order to be impacted, the same private key for an honest issuer and a malicious user must be used when signing JWTs. In that case, a malicious user could fashion signed JWTs with the malicious issuer URL that may be granted for the honest issuer.

    Recommended action: Upgrade to 5.1.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 7.5MavenPublished

    Spring Security and Spring Framework may not recognize certain paths that should be protected

    CVE-2016-5007 · GHSA-8crv-49fr-2h6j

    Affected
    • Maven org.springframework.security:spring-security-core < 4.1.1
    Fixed in
    4.1.1· Vendor fix available
    Issue
    Both Spring Security 3.2.x, 4.0.x, 4.1.0 and the Spring Framework 3.2.x, 4.0.x, 4.1.x, 4.2.x (as well as other unsupported versions) rely on URL pattern mappings for authorization and for mapping requests to controllers respectively. Differences in the strictness of the pattern matching mechanisms, for example with regards to space trimming in path segments, can lead Spring Security to not recognize certain paths as not protected that are in fact mapped to Spring MVC controllers that should be protected. The problem is compounded by the fact that the Spring Framework provides richer features with regards to pattern matching as well as by the fact that pattern matching in each Spring Security and the Spring Framework can easily be customized creating additional differences.

    Recommended action: Upgrade to 4.1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Medium, CVSS 5.3MavenPublished

    Improper Input Validation in org.springframework.security:spring-security-core, org.springframework.security:spring-security-core , and org.springframework:spring-core

    CVE-2018-1199 · GHSA-v596-fwhq-8x48

    Affected
    • Maven org.springframework.security:spring-security-core >= 4.1.0, < 4.1.5; >= 4.2.0, < 4.2.4; >= 5.0.0, < 5.0.1
    Fixed in
    4.1.54.2.45.0.1· Vendor fix available
    Issue
    Spring Security (Spring Security 4.1.x before 4.1.5, 4.2.x before 4.2.4, and 5.0.x before 5.0.1; and Spring Framework 4.3.x before 4.3.14 and 5.0.x before 5.0.3) does not consider URL path parameters when processing security constraints. By adding a URL path parameter with special encodings, an attacker may be able to bypass a security constraint. The root cause of this issue is a lack of clarity regarding the handling of path parameters in the Servlet Specification. Some Servlet containers include path parameters in the value returned for getPathInfo() and some do not. Spring Security uses the value returned by getPathInfo() as part of the process of mapping requests to security constraints. In this particular attack, different character encodings used in path parameters allows secured Spring MVC static resource URLs to be bypassed.

    Recommended action: Upgrade to 5.0.1, 4.2.4 or 4.1.5 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →