High, CVSS 7.3MavenPublished
Insufficiently Protected Credentials and Improper Authentication in Spring Security
CVE-2019-11272 · GHSA-v33x-prhc-gph5
- Affected
- Maven org.springframework.security:spring-security-cas <= 4.2.12.RELEASE
- Fixed in
- 4.2.13.RELEASE· Vendor fix available
- Issue
- Spring Security, versions 4.2.x up to 4.2.12, and older unsupported versions support plain text passwords using PlaintextPasswordEncoder. If an application using an affected version of Spring Security is leveraging PlaintextPasswordEncoder and a user has a null encoded password, a malicious user (or attacker) can authenticate using a password of ?null?.
Recommended action: Upgrade to 4.2.13.RELEASE or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.