Skip to content

← Public intelligence

Maven package

org.springframework.security:spring-security-bom

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.8MavenPublished

    Privilege escalation in spring security

    CVE-2021-22112 · GHSA-gq28-h5vg-8prx

    Affected
    • Maven org.springframework.security:spring-security-bom >= 5.4.0, < 5.4.4; >= 5.3.0, < 5.3.8; < 5.2.9
    Fixed in
    5.3.85.2.95.4.4· Vendor fix available
    Issue
    Spring Security 5.4.x prior to 5.4.4, 5.3.x prior to 5.3.8.RELEASE, 5.2.x prior to 5.2.9.RELEASE, and older unsupported versions can fail to save the SecurityContext if it is changed more than once in a single request.A malicious user cannot cause the bug to happen (it must be programmed in). However, if the application's intent is to only allow the user to run with elevated privileges in a small portion of the application, the bug can be leveraged to extend those privileges to the rest of the application.

    Recommended action: Upgrade to 5.4.4, 5.3.8 or 5.2.9 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →