Low, CVSS 3.3MavenPublished
Spring Cloud Contract vulnerable to local information disclosure
CVE-2024-22236 · GHSA-p6rp-mx85-m459
- Affected
- Maven org.springframework.cloud:spring-cloud-contract-shade >= 4.1.0, <= 4.1.0; >= 4.0.0, < 4.0.5; >= 3.1.0, < 3.1.10
- Fixed in
- 3.1.104.1.14.0.5· Vendor fix available
- Issue
- In Spring Cloud Contract, versions 4.1.x prior to 4.1.1, versions 4.0.x prior to 4.0.5, and versions 3.1.x prior to 3.1.10, test execution is vulnerable to local information disclosure via temporary directory created with unsafe permissions through the shaded com.google.guava:guava dependency in the org.springframework.cloud:spring-cloud-contract-shade dependency.
Recommended action: Upgrade to 4.1.1, 4.0.5 or 3.1.10 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.