Critical, CVSS 9.8Exploited · CISA KEVMavenPublished
Remote Code Execution in Spring Framework
CVE-2022-22965 · GHSA-36p3-wjmg-h94x
- Affected
- Maven org.springframework.boot:spring-boot-starter-webflux < 2.5.12; >= 2.6.0, < 2.6.6
- Fixed in
- 2.6.62.5.12· Vendor fix available
- Issue
- Spring Framework prior to versions 5.2.20 and 5.3.18 contains a remote code execution vulnerability known as Spring4Shell. Impact A Spring MVC or Spring WebFlux application running on JDK 9+ may be vulnerable to remote code execution (RCE) via data binding. The specific exploit requires the application to run on Tomcat as a WAR deployment. If the application is deployed as a Spring Boot executable jar, i.e. the default, it is not vulnerable to the exploit. However, the nature of the vulnerability is more general, and there may be other ways to exploit it. These are the prerequisites for the exploit: - JDK 9 or higher - Apache Tomcat as the Servlet container - Packaged as WAR - spring-webmvc or spring-webflux dependency Patches - Spring Framework 5.3.18 and 5.2.20 - Spring Boot 2.6.6 and 2.5.12 Workarounds For those who are unable to upgrade, leaked reports recommend setting disallowedFields on WebDataBinder through an @ControllerAdvice. This works generally, but as a centrally…
Recommended action: Upgrade to 2.6.6 or 2.5.12 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.