Skip to content

← Public intelligence

Maven package

org.springframework.ai:spring-ai-bedrock-converse

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.6MavenPublished

    Spring AI: Insufficient Validation causes SSRF when processing multimodal messages with user-supplied URLs

    CVE-2026-22742 · GHSA-mhrg-94vw-45c5

    Affected
    • Maven org.springframework.ai:spring-ai-bedrock-converse >= 1.0.0-M5, < 1.0.5; >= 1.1.0-M1, < 1.1.4
    Fixed in
    1.1.41.0.5· Vendor fix available
    Issue
    Spring AI's spring-ai-bedrock-converse contains a Server-Side Request Forgery (SSRF) vulnerability in BedrockProxyChatModel when processing multimodal messages that include user-supplied media URLs. Insufficient validation of those URLs allows an attacker to induce the server to issue HTTP requests to unintended internal or external destinations. This issue affects Spring AI: from 1.0.0 before 1.0.5, from 1.1.0 before 1.1.4.

    Recommended action: Upgrade to 1.1.4 or 1.0.5 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →