Skip to content

← Public intelligence

Maven package

org.springframework:spring-websocket

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.8MavenPublished

    Spring Framework Predictable Session ID in WebSocket Module

    CVE-2026-41838 · GHSA-q723-847q-5g8g

    Affected
    • Maven org.springframework:spring-websocket >= 7.0.0, <= 7.0.7; >= 6.2.0, <= 6.2.18; >= 6.1.0, <= 6.1.27; <= 5.3.48
    Fixed in
    7.0.86.2.19· Partial vendor fix
    Issue
    IDs for WebSocket sessions in the spring-websocket module are not cryptographically unpredictable, which may be possible to exploit in combination with inadequate authorization rules. Affected versions: Spring Framework 7.0.0 through 7.0.7; 6.2.0 through 6.2.18; 6.1.0 through 6.1.27; 5.3.0 through 5.3.48.

    Recommended action: Upgrade to 7.0.8 or 6.2.19 by release line; some affected versions have no fix yet, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 4.3MavenPublished

    Spring Framework STOMP over WebSocket applications may allow attackers to send unauthorized messages

    CVE-2025-41254 · GHSA-7fch-4f2f-jcgm

    Affected
    • Maven org.springframework:spring-websocket >= 6.2.0, < 6.2.12; >= 6.1.0, <= 6.1.21; >= 6.0.0, <= 6.0.23; <= 5.3.39
    Fixed in
    6.2.12· Partial vendor fix
    Issue
    STOMP over WebSocket applications may be vulnerable to a security bypass that allows an attacker to send unauthorized messages. Affected Spring Products and Versions Spring Framework: 6.2.0 - 6.2.11 6.1.0 - 6.1.23 6.0.x - 6.0.29 5.3.0 - 5.3.45 Older, unsupported versions are also affected. Mitigation Users of affected versions should upgrade to the corresponding fixed version. Affected version(s) Fix version | Availability -|- 6.2.x | 6.2.12 OSS 6.1.x | 6.1.24 Commercial https://enterprise.spring.io/ 6.0.x | N/A Out of support https://spring.io/projects/spring-framework#support 5.3.x | 5.3.46 Commercial https://enterprise.spring.io/ No further mitigation steps are necessary. CreditThis vulnerability was discovered and responsibly reported by Jannis Kaiser.

    Recommended action: Upgrade to 6.2.12; some affected versions have no fix yet, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →