Medium, CVSS 6.5MavenPublished
Improper Input Validation in Spring Framework
CVE-2020-5421 · GHSA-rv39-3qh7-9v7w
- Affected
- Maven org.springframework:spring-framework-bom >= 5.2.0, <= 5.2.8; >= 5.1.0, <= 5.1.17; >= 5.0.0, <= 5.0.18; < 4.3.29
- Fixed in
- 4.3.295.2.95.1.185.0.19· Vendor fix available
- Issue
- In Spring Framework versions 5.2.0 - 5.2.8, 5.1.0 - 5.1.17, 5.0.0 - 5.0.18, 4.3.0 - 4.3.28, and older unsupported versions, the protections against RFD attacks from CVE-2015-5211 may be bypassed depending on the browser used through the use of a jsessionid path parameter.
Recommended action: Upgrade to 5.2.9, 5.1.18, 5.0.19 or 4.3.29 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.