Skip to content

← Public intelligence

Maven package

org.springframework:spring-beans

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5MavenPublished

    Denial of service in Spring Framework

    CVE-2022-22970 · GHSA-hh26-6xwr-ggv7

    Affected
    • Maven org.springframework:spring-beans <= 5.2.21.RELEASE; >= 5.3.0, < 5.3.20
    Fixed in
    5.3.205.2.22.RELEASE· Vendor fix available
    Issue
    In spring framework versions prior to 5.3.20+ , 5.2.22+ and old unsupported versions, applications that handle file uploads are vulnerable to DoS attack if they rely on data binding to set a MultipartFile or javax.servlet.Part to a field in a model object.

    Recommended action: Upgrade to 5.3.20 or 5.2.22.RELEASE by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8Exploited · CISA KEVMavenPublished

    Remote Code Execution in Spring Framework

    CVE-2022-22965 · GHSA-36p3-wjmg-h94x

    Affected
    • Maven org.springframework:spring-beans >= 5.3.0, < 5.3.18; < 5.2.20.RELEASE
    Fixed in
    5.3.185.2.20.RELEASE· Vendor fix available
    Issue
    Spring Framework prior to versions 5.2.20 and 5.3.18 contains a remote code execution vulnerability known as Spring4Shell. Impact A Spring MVC or Spring WebFlux application running on JDK 9+ may be vulnerable to remote code execution (RCE) via data binding. The specific exploit requires the application to run on Tomcat as a WAR deployment. If the application is deployed as a Spring Boot executable jar, i.e. the default, it is not vulnerable to the exploit. However, the nature of the vulnerability is more general, and there may be other ways to exploit it. These are the prerequisites for the exploit: - JDK 9 or higher - Apache Tomcat as the Servlet container - Packaged as WAR - spring-webmvc or spring-webflux dependency Patches - Spring Framework 5.3.18 and 5.2.20 - Spring Boot 2.6.6 and 2.5.12 Workarounds For those who are unable to upgrade, leaked reports recommend setting disallowedFields on WebDataBinder through an @ControllerAdvice. This works generally, but as a centrally…

    Recommended action: Upgrade to 5.3.18 or 5.2.20.RELEASE by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:cisa.gov (1)github.com (2)Source checked Evidence →