Skip to content

← Public intelligence

Maven package

org.restlet.jse:org.restlet

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedMavenPublished

    Restlet Arbitrary Java Code Execution via a serialized object

    CVE-2013-4271 · GHSA-f3mv-g3xr-fp7w

    Affected
    • Maven org.restlet.jse:org.restlet < 2.1.4
    Fixed in
    2.1.4· Vendor fix available
    Issue
    The default configuration of the ObjectRepresentation class in Restlet before 2.1.4 deserializes objects from untrusted sources, which allows remote attackers to execute arbitrary Java code via a serialized object, a different vulnerability than CVE-2013-4221.

    Recommended action: Upgrade to 2.1.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. UnratedMavenPublished

    Restlet is vulnerable to Arbitrary Java Code Execution via crafted XML

    CVE-2013-4221 · GHSA-92j2-5r7p-6hjw

    Affected
    • Maven org.restlet.jse:org.restlet < 2.1.4
    Fixed in
    2.1.4· Vendor fix available
    Issue
    The default configuration of the ObjectRepresentation class in Restlet before 2.1.4 deserializes objects from untrusted sources using the Java XMLDecoder, which allows remote attackers to execute arbitrary Java code via crafted XML.

    Recommended action: Upgrade to 2.1.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. UnratedMavenPublished

    Moderate severity vulnerability that affects org.restlet.jse:org.restlet

    CVE-2014-1868 · GHSA-73cq-fhp3-8rpw

    Affected
    • Maven org.restlet.jse:org.restlet >= 2.1.0, < 2.1.7
    Fixed in
    2.1.7· Vendor fix available
    Issue
    Restlet Framework 2.1.x before 2.1.7 and 2.x.x before 2.2 RC1, when using XMLRepresentation or XML serializers, allows attackers to cause a denial of service via an XML Entity Expansion (XEE) attack.

    Recommended action: Upgrade to 2.1.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 7.5MavenPublished

    Restlet Framework allows remote attackers to access arbitrary files via a crafted REST API HTTP request

    CVE-2017-14949 · GHSA-cvj4-g3gx-8vqq

    Affected
    • Maven org.restlet.jse:org.restlet < 2.3.12
    Fixed in
    2.3.12· Vendor fix available
    Issue
    Restlet Framework before 2.3.12 allows remote attackers to access arbitrary files via a crafted REST API HTTP request that conducts an XXE attack, because only general external entities (not parameter external entities) are properly considered. This is related to XmlRepresentation, DOMRepresentation, SaxRepresentation, and JacksonRepresentation.

    Recommended action: Upgrade to 2.3.12 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →