Skip to content

← Public intelligence

Maven package

org.pac4j:pac4j-jwt

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 10.0MavenPublished

    pac4j-jwt: JwtAuthenticator Authentication Bypass via JWE-Wrapped PlainJWT

    CVE-2026-29000 · GHSA-pm7g-w2cf-q238

    Affected
    • Maven org.pac4j:pac4j-jwt >= 6.0.4.1, < 6.3.3; >= 5.0.0-RC1, < 5.7.9; < 4.5.9
    Fixed in
    6.3.34.5.95.7.9· Vendor fix available
    Issue
    pac4j-jwt versions prior to 4.5.9, 5.7.9, and 6.3.3 contain an authentication bypass vulnerability in JwtAuthenticator when processing encrypted JWTs that allows remote attackers to forge authentication tokens. Attackers who possess the server's RSA public key can create a JWE-wrapped PlainJWT with arbitrary subject and role claims, bypassing signature verification to authenticate as any user including administrators.

    Recommended action: Upgrade to 6.3.3, 5.7.9 or 4.5.9 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →