Skip to content

← Public intelligence

Maven package

org.opensearch:opensearch-common

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.3MavenPublished

    OpenSearch is vulnerable to DoS via complex query_string inputs

    CVE-2025-9624 · GHSA-mw3v-mmfw-3x2g

    Affected
    • Maven org.opensearch:opensearch-common >= 3.0.0, < 3.3.0; < 2.19.4
    Fixed in
    3.3.02.19.4· Vendor fix available
    Issue
    A vulnerability in OpenSearch allows attackers to cause Denial of Service (DoS) by submitting complex querystring inputs. This issue affects all OpenSearch versions below 2.19.4 and versions 3.0.0 through 3.2.0.

    Recommended action: Upgrade to 3.3.0 or 2.19.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →