High, CVSS 8.8MavenPublished
OpenNMS Horizon XXE Injection Vulnerability
CVE-2023-0871 · GHSA-2qc8-r663-v864
- Affected
- Maven org.opennms.core:org.opennms.core.xml >= 31.0.8, < 32.0.2
- Fixed in
- 32.0.2· Vendor fix available
- Issue
- XXE injection in /rtc/post/ endpoint in OpenNMS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms is vulnerable to XML external entity (XXE) injection, which can be used for instance to force Horizon to make arbitrary HTTP requests to internal and external services. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
Recommended action: Upgrade to 32.0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.