High, CVSS 7.1MavenPublished
OpenNMS vulnerable to remote code execution
CVE-2023-40313 · GHSA-5m5f-qg8r-p9qf
- Affected
- Maven org.opennms:opennms-base-assembly < 32.0.2
- Fixed in
- 32.0.2· Vendor fix available
- Issue
- A BeanShell interpreter in remote server mode runs in OpenNMS Horizon versions earlier than 32.0.2 and in related Meridian versions which could allow arbitrary remote Java code execution. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
Recommended action: Upgrade to 32.0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.