Skip to content

← Public intelligence

Maven package

org.opennms:opennms

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

8 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1MavenPublished

    OpenNMS Meridian and Horizon vulnerable to Cross-site Scripting

    CVE-2023-0867 · GHSA-mjv2-6jv4-vrg7

    Affected
    • Maven org.opennms:opennms < 31.0.4
    Fixed in
    31.0.4· Vendor fix available
    Issue
    Multiple stored and reflected cross-site scripting vulnerabilities in webapp jsp pages in multiple versions of OpenNMS Meridian and Horizon could allow an attacker access to confidential session information.

    Recommended action: Upgrade to 31.0.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.5MavenPublished

    OpenNMS has potential Insertion of Sensitive Information into Log File vulnerability

    CVE-2023-0815 · GHSA-9xpj-mvp2-3943

    Affected
    • Maven org.opennms:opennms < 31.0.4
    Fixed in
    31.0.4· Vendor fix available
    Issue
    Potential Insertion of Sensitive Information into Jetty Log Files in multiple versions of OpenNMS Meridian and Horizon could allow disclosure of usernames and passwords if the logging level is set to debug.

    Recommended action: Upgrade to 31.0.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 6.1MavenPublished

    OpenNMS Horizon and Meridian vulnerable to Cross-site Scripting

    CVE-2023-0846 · GHSA-79jr-8fhm-8wv3

    Affected
    • Maven org.opennms:opennms < 31.0.3
    Fixed in
    31.0.3· Vendor fix available
    Issue
    Unauthenticated, stored cross-site scripting in the display of alarm reduction keys in multiple versions of OpenNMS Horizon and Meridian could allow an attacker access to confidential session information.

    Recommended action: Upgrade to 31.0.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 8.8MavenPublished

    OpenNMS Horizon RCE via JEXL2 expression

    CVE-2021-3396 · GHSA-c3mp-9vx3-2rvv

    Affected
    • Maven org.opennms:opennms >= 16.0.0, <= 27.0.3
    Fixed in
    27.0.4· Vendor fix available
    Issue
    OpenNMS Meridian 2016, 2017, 2018 before 2018.1.25, 2019 before 2019.1.16, and 2020 before 2020.1.5, Horizon 1.2 through 27.0.4, and Newts <1.5.3 has Incorrect Access Control, which allows local and remote code execution using JEXL expressions.

    Recommended action: Upgrade to 27.0.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Medium, CVSS 4.8MavenPublished

    Cross-site Scripting in OpenNMS Horizon

    CVE-2021-25933 · GHSA-jjhw-5mxp-2g2q

    Affected
    • Maven org.opennms:opennms >= 1.0.0, < 27.1.1
    Fixed in
    27.1.1· Vendor fix available
    Issue
    In OpenNMS Horizon, versions opennms-1-0-stable through opennms-27.1.1; OpenNMS Meridian, versions meridian-foundation-2015.1.0-1 through meridian-foundation-2019.1.18-1; meridian-foundation-2020.1.0-1 through meridian-foundation-2020.1.6-1 are vulnerable to Stored Cross-Site Scripting, since the function validateFormInput() performs improper validation checks on the input sent to the groupName and groupComment parameters. Due to this flaw, an authenticated attacker could inject arbitrary script and trick other admin users into downloading malicious files which can cause severe damage to the organization using opennms.

    Recommended action: Upgrade to 27.1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. Medium, CVSS 4.8MavenPublished

    Cross-site Scripting in OpenNMS Horizon

    CVE-2021-25929 · GHSA-jmv4-73v2-pvgc

    Affected
    • Maven org.opennms:opennms >= 1.0.0, < 27.1.1
    Fixed in
    27.1.1· Vendor fix available
    Issue
    In OpenNMS Horizon, versions opennms-1-0-stable through opennms-27.1.1; OpenNMS Meridian, versions meridian-foundation-2015.1.0-1 through meridian-foundation-2019.1.18-1; meridian-foundation-2020.1.0-1 through meridian-foundation-2020.1.6-1 are vulnerable to Stored Cross-Site Scripting since there is no validation on the input being sent to the name parameter in noticeWizard endpoint. Due to this flaw an authenticated attacker could inject arbitrary script and trick other admin users into downloading malicious files.

    Recommended action: Upgrade to 27.1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  7. High, CVSS 8.8MavenPublished

    Cross-Site Request Forgery in OpenNMS Horizon

    CVE-2021-25931 · GHSA-2rq5-68hm-h4j8

    Affected
    • Maven org.opennms:opennms >= 1.0.0, < 27.1.1
    Fixed in
    27.1.1· Vendor fix available
    Issue
    In OpenNMS Horizon, versions opennms-1-0-stable through opennms-27.1.1; OpenNMS Meridian, versions meridian-foundation-2015.1.0-1 through meridian-foundation-2019.1.18-1; meridian-foundation-2020.1.0-1 through meridian-foundation-2020.1.6-1 are vulnerable to CSRF, due to no CSRF protection at /opennms/admin/userGroupView/users/updateUser. This flaw allows assigning ROLEADMIN security role to a normal user. Using this flaw, an attacker can trick the admin user to assign administrator privileges to a normal user by enticing him to click upon an attacker-controlled website.

    Recommended action: Upgrade to 27.1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  8. Medium, CVSS 4.3MavenPublished

    Cross-Site Request Forgery in OpenNMS Horizon

    CVE-2021-25930 · GHSA-p63h-7hw8-5cw4

    Affected
    • Maven org.opennms:opennms >= 1.0.0, < 27.1.1
    Fixed in
    27.1.1· Vendor fix available
    Issue
    In OpenNMS Horizon, versions opennms-1-0-stable through opennms-27.1.1; OpenNMS Meridian, versions meridian-foundation-2015.1.0-1 through meridian-foundation-2019.1.18-1; meridian-foundation-2020.1.0-1 through meridian-foundation-2020.1.6-1 are vulnerable to CSRF, due to no CSRF protection, and since there is no validation of an existing user name while renaming a user. As a result, privileges of the renamed user are being overwritten by the old user and the old user is being deleted from the user list.

    Recommended action: Upgrade to 27.1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →