Skip to content

← Public intelligence

Maven package

org.lucee:lucee

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 10.0MavenPublished

    Lucee RCE/XXE Vulnerability

    CVE-2023-38693 · GHSA-vwjx-mmwm-pwrf

    Affected
    • Maven org.lucee:lucee >= 5.3.10.79-RC, < 5.3.12.1; >= 5.4.0.65-RC, < 5.4.3.2; <= 5.3.7.59; >= 5.3.8.132-RC, < 5.3.8.236; >= 5.3.9.113, < 5.3.9.173
    Fixed in
    5.3.9.1735.3.8.2365.4.3.25.3.12.1· Partial vendor fix
    Issue
    Impact The Lucee team received a responsible disclosure of a security vulnerability which affects all previous releases of Lucee. After reviewing the report and confirming the vulnerability, the Lucee team then conducted a further security review and found additional vulnerabilities which have been addressed as part of this this security update. Patches Lucee 5.4.3.2 and 5.3.12.1 stable releases have been patched with additional hardening The older releases, 5.3.7.59., 5.3.8.236 and 5.3.9.173 have also been patched Any users running older release, should plan to immediately upgrade to the latest stable release 6.0 will have a RC as it's not yet released

    Recommended action: Upgrade to 5.4.3.2, 5.3.12.1, 5.3.9.173 or 5.3.8.236 by release line; some affected versions have no fix yet, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →