Skip to content

← Public intelligence

Maven package

org.keycloak:keycloak-server-spi-private

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

7 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.3MavenPublished

    Keycloak Vulnerable to Incorrect Authorization

    CVE-2026-9791 · GHSA-4q93-v92x-p89f

    Affected
    • Maven org.keycloak:keycloak-server-spi-private >= 26.5.0, < 26.6.3; <= 26.4.7
    Fixed in
    26.6.3· Partial vendor fix
    Issue
    A flaw was found in Keycloak. An authenticated user with existing organization membership can exploit this flaw by accessing user-facing APIs, such as the account API or by requesting an OpenID Connect (OIDC) token with the 'organization' scope. This allows organization metadata to be disclosed in tokens, even after an administrator has explicitly disabled the Organizations feature, potentially leading to incorrect authorization decisions by resource servers.

    Recommended action: Upgrade to 26.6.3; some affected versions have no fix yet, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.8MavenPublished

    Keycloak Vulnerable to Improper Validation of Specified Quantity in Input

    CVE-2026-9704 · GHSA-rr5q-3xwr-f323

    Affected
    • Maven org.keycloak:keycloak-server-spi-private < 26.6.3
    Fixed in
    26.6.3· Vendor fix available
    Issue
    A flaw was found in Keycloak. An authenticated user with low privileges can exploit this vulnerability by sending an oversized subjecttoken JSON Web Token (JWT) to the TokenEndpoint. When the token exceeds a 4000-character limit, it is silently dropped, causing the system to fall back to client credentials. This allows the user to gain the permissions of the client's service account, leading to privilege escalation.

    Recommended action: Upgrade to 26.6.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 4.3MavenPublished

    Keycloak: Missing Role Enforcement on UMA 2.0 Permission Ticket Endpoint Leads to Information Disclosure

    CVE-2026-3190 · GHSA-q35r-vvhv-vx5h

    Affected
    • Maven org.keycloak:keycloak-server-spi-private < 26.5.6
    Fixed in
    26.5.6· Vendor fix available
    Issue
    A flaw was found in Keycloak. The User-Managed Access (UMA) 2.0 Protection API endpoint for permission tickets fails to enforce the umaprotection role check. This allows any authenticated user with a token issued for a resource server client, even without the umaprotection role, to enumerate all permission tickets in the system. This vulnerability partial leads to information disclosure.

    Recommended action: Upgrade to 26.5.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 8.1MavenPublished

    Keycloak: Unauthorized authentication via disabled SAML Identity Provider

    CVE-2026-2603 · GHSA-x4p7-7chp-64hq

    Affected
    • Maven org.keycloak:keycloak-server-spi-private < 26.5.5
    Fixed in
    26.5.5· Vendor fix available
    Issue
    A flaw was found in Keycloak. A remote attacker could bypass security controls by sending a valid SAML response from an external Identity Provider (IdP) to the Keycloak SAML endpoint for IdP-initiated broker logins. This allows the attacker to complete broker logins even when the SAML Identity Provider is disabled, leading to unauthorized authentication.

    Recommended action: Upgrade to 26.5.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Medium, CVSS 4.9MavenPublished

    Keycloak Server Private SPI: Improper Access Control Allows Administrators to Bypass Attribute Visibility Restrictions and Modify Unmanaged User Profile Attributes

    CVE-2026-0871 · GHSA-v4jw-m6rm-399h

    Affected
    • Maven org.keycloak:keycloak-server-spi-private < 26.5.2
    Fixed in
    26.5.2· Vendor fix available
    Issue
    A flaw was found in Keycloak. An administrator with manage-users permission can bypass the "Only administrators can view" setting for unmanaged attributes, allowing them to modify these attributes. This improper access control can lead to unauthorized changes to user profiles, even when the system is configured to restrict such modifications.

    Recommended action: Upgrade to 26.5.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. Low, CVSS 3.5MavenPublished

    Client Spoofing within the Keycloak Device Authorisation Grant

    CVE-2023-2585 · GHSA-f5h4-wmp5-xhg6

    Affected
    • Maven org.keycloak:keycloak-server-spi-private < 21.1.2
    Fixed in
    21.1.2· Vendor fix available
    Issue
    Under certain pre-conditions the vulnerability allows an attacker to spoof parts of the device flow and use a devicecode to retrieve an access token for other OAuth clients.

    Recommended action: Upgrade to 21.1.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  7. Medium, CVSS 4.8MavenPublished

    Cross-site Scripting in keycloak

    CVE-2020-10776 · GHSA-484q-784p-8m5h

    Affected
    • Maven org.keycloak:keycloak-server-spi-private < 12.0.0
    Fixed in
    12.0.0· Vendor fix available
    Issue
    A flaw was found in Keycloak before version 12.0.0, where it is possible to add unsafe schemes for the redirecturi parameter. This flaw allows an attacker to perform a Cross-site scripting attack.

    Recommended action: Upgrade to 12.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →