Skip to content

← Public intelligence

Maven package

org.jvnet.hudson.plugins:warnings

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.8MavenPublished

    CSRF vulnerability in Jenkins warnings Plugin allows remote code execution

    CVE-2020-2280 · GHSA-q564-vvx8-9388

    Affected
    • Maven org.jvnet.hudson.plugins:warnings <= 5.0.1
    Fixed in
    5.0.2· Vendor fix available
    Issue
    warnings Plugin 5.0.1 and earlier does not require POST requests for a form validation method intended for testing custom warnings parsers, resulting in a cross-site request forgery (CSRF) vulnerability. This vulnerability allows attackers to execute arbitrary code. warnings Plugin 5.0.2 requires POST requests for the affected form validation method. This vulnerability was caused by an incomplete fix to SECURITY-1295.

    Recommended action: Upgrade to 5.0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 8.8MavenPublished

    XXE vulnerability Jenkins Warnings Plugin

    CVE-2018-1000012 · GHSA-p498-rpcw-3578

    Affected
    • Maven org.jvnet.hudson.plugins:warnings <= 4.64
    Fixed in
    4.65· Vendor fix available
    Issue
    Jenkins Warnings Plugin 4.64 and earlier processes XML external entities in files it parses as part of the build process, allowing attackers with user permissions in Jenkins to extract secrets from the Jenkins master, perform server-side request forgery, or denial-of-service attacks.

    Recommended action: Upgrade to 4.65 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 8.8MavenPublished

    Sandbox Bypass via CSRF in Jenkins Warnings Plugin

    CVE-2019-1003007 · GHSA-mmrv-3cqg-hpf9

    Affected
    • Maven org.jvnet.hudson.plugins:warnings <= 5.0.0
    Fixed in
    5.0.1· Vendor fix available
    Issue
    A cross-site request forgery vulnerability exists in Jenkins Warnings Plugin 5.0.0 and earlier in src/main/java/hudson/plugins/warnings/GroovyParser.java that allows attackers to execute arbitrary code via a form validation HTTP endpoint.

    Recommended action: Upgrade to 5.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →