Skip to content

← Public intelligence

Maven package

org.jvnet.hudson.plugins:hipchat

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.5MavenPublished

    Jenkins HipChat Plugin allows attackers with Overall/Read access to obtain credential IDs

    CVE-2018-1000419 · GHSA-798p-53r7-mgw9

    Affected
    • Maven org.jvnet.hudson.plugins:hipchat < 2.2.1
    Fixed in
    2.2.1· Vendor fix available
    Issue
    An improper authorization vulnerability exists in Jenkins HipChat Plugin 2.2.0 and earlier in HipChatNotifier.java that allows attackers with Overall/Read access to obtain credentials IDs for credentials stored in Jenkins. As of version 2.2.1, an enumeration of credentials IDs in this plugin requires Overall/Administer permission.

    Recommended action: Upgrade to 2.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 8.8MavenPublished

    Jenkins HipChat Plugin allows credential capture due to incorrect authorization

    CVE-2018-1000418 · GHSA-w3f7-2qfw-348x

    Affected
    • Maven org.jvnet.hudson.plugins:hipchat < 2.2.1
    Fixed in
    2.2.1· Vendor fix available
    Issue
    An improper authorization vulnerability exists in Jenkins HipChat Plugin 2.2.0 and earlier in HipChatNotifier.java that allows attackers with Overall/Read access to send test notifications to an attacker-specified HipChat server with attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins. As of version 2.2.1, this form validation method requires POST requests and Overall/Administer permissions.

    Recommended action: Upgrade to 2.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →