Medium, CVSS 5.4MavenPublished
Jenkins Groovy Postbuild Plugin vulnerable to Cross-site Scripting
CVE-2018-1000202 · GHSA-38ch-x695-m794
- Affected
- Maven org.jvnet.hudson.plugins:groovy-postbuild <= 2.3.1
- Fixed in
- 2.4· Vendor fix available
- Issue
- A persisted cross-site scripting vulnerability exists in Jenkins Groovy Postbuild Plugin 2.3.1 and older in various Jelly files that allows attackers able to control build badge content to define JavaScript that would be executed in another user's browser when that other user performs some UI actions.
Recommended action: Upgrade to 2.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.