Skip to content

← Public intelligence

Maven package

org.jvnet.hudson.plugins:analysis-core

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.5MavenPublished

    Missing permission check in Jenkins Static Analysis Utilities Plugin

    CVE-2019-10308 · GHSA-vvfj-p4jf-j8rm

    Affected
    • Maven org.jvnet.hudson.plugins:analysis-core <= 1.95
    Fixed in
    1.96· Vendor fix available
    Issue
    A missing permission check in Jenkins Static Analysis Utilities Plugin 1.95 and earlier in the DefaultGraphConfigurationView#doSave form handler method allowed attackers with Overall/Read permission to change the per-job default graph configuration for all users.

    Recommended action: Upgrade to 1.96 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 4.3MavenPublished

    Jenkins Static Analysis Utilities Plugin is vulnerable to Cross-site request forgery vulnerability

    CVE-2019-10307 · GHSA-3v9f-4vff-rx42

    Affected
    • Maven org.jvnet.hudson.plugins:analysis-core <= 1.95
    Fixed in
    1.96· Vendor fix available
    Issue
    Jenkins analysis-core Plugin has the capability to allow other plugins to display trend graphs for their static analysis results. analysis-core Plugin provides the configuration form for the default settings of each graph. The configuration form and form submission handler did not perform a permission check, allowing attackers with Job/Read access to change the per-job graph configuration defaults for all users. Additionally, the form submission handler did not require POST requests, resulting in a cross-site request forgery vulnerability. analysis-core Plugin now requires Job/Configure permission and POST requests to configure the per-job graph defaults for all users.

    Recommended action: Upgrade to 1.96 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 5.4MavenPublished

    Persistent XSS vulnerability in Static Analysis Utilities

    CVE-2017-1000102 · GHSA-9c2p-99pg-c4j9

    Affected
    • Maven org.jvnet.hudson.plugins:analysis-core <= 1.91
    Fixed in
    1.92· Vendor fix available
    Issue
    The Details view of some Static Analysis Utilities based plugins, was vulnerable to a persisted cross-site scripting vulnerability: Malicious users able to influence the input to these plugins, for example the console output which is parsed to extract build warnings (Warnings Plugin), could insert arbitrary HTML into this view.

    Recommended action: Upgrade to 1.92 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →