Skip to content

← Public intelligence

Maven package

org.jruby:jruby-stdlib

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

7 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.5MavenPublished

    RubyGems Path Traversal vulnerability

    CVE-2018-1000079 · GHSA-8qxg-mff5-j3wc

    Affected
    • Maven org.jruby:jruby-stdlib < 9.1.16.0
    Fixed in
    9.1.16.0· Vendor fix available
    Issue
    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in gem installation that can result in the gem writing to arbitrary filesystem locations during installation. This attack appears to be exploitable via installation of a malicious gem. This vulnerability is fixed in 2.7.6.

    Recommended action: Upgrade to 9.1.16.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.8MavenPublished

    RubyGems Deserialization of Untrusted Data vulnerability

    CVE-2018-1000074 · GHSA-qj2w-mw2r-pv39

    Affected
    • Maven org.jruby:jruby-stdlib < 9.1.16.0
    Fixed in
    9.1.16.0· Vendor fix available
    Issue
    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Deserialization of Untrusted Data vulnerability in owner command that can result in code execution. This attack requires the victim to run the gem owner command on a gem with a specially crafted YAML file. This vulnerability is fixed in 2.7.6.

    Recommended action: Upgrade to 9.1.16.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Critical, CVSS 9.8MavenPublished

    RubyGems Improper Verification of Cryptographic Signature vulnerability

    CVE-2018-1000076 · GHSA-mc6j-h948-v2p6

    Affected
    • Maven org.jruby:jruby-stdlib < 9.1.16.0
    Fixed in
    9.1.16.0· Vendor fix available
    Issue
    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, and Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contain an Improper Verification of Cryptographic Signature vulnerability in package.rb. This can result in a mis-signed gem being installed, as the tarball would contain multiple gem signatures. This vulnerability has been fixed in 2.7.6.

    Recommended action: Upgrade to 9.1.16.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 5.3MavenPublished

    RubyGems Improper Input Validation vulnerability

    CVE-2018-1000077 · GHSA-gv86-43rv-79m2

    Affected
    • Maven org.jruby:jruby-stdlib < 9.1.16.0
    Fixed in
    9.1.16.0· Vendor fix available
    Issue
    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Improper Input Validation vulnerability in ruby gems specification homepage attribute that can result in a malicious gem setting an invalid homepage URL. This vulnerability is fixed in 2.7.6.

    Recommended action: Upgrade to 9.1.16.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Medium, CVSS 6.1MavenPublished

    RubyGems Cross-site Scripting vulnerability

    CVE-2018-1000078 · GHSA-87qx-g5wg-mwmj

    Affected
    • Maven org.jruby:jruby-stdlib < 9.1.16.0
    Fixed in
    9.1.16.0· Vendor fix available
    Issue
    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Cross Site Scripting (XSS) vulnerability in gem server display of homepage attribute that can result in XSS. This attack requires the victim to browse to a malicious gem on a vulnerable gem server. This vulnerability is fixed in 2.7.6.

    Recommended action: Upgrade to 9.1.16.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. High, CVSS 7.5MavenPublished

    RubyGems Infinite Loop vulnerability

    CVE-2018-1000075 · GHSA-74pv-v9gh-h25p

    Affected
    • Maven org.jruby:jruby-stdlib < 9.1.16.0
    Fixed in
    9.1.16.0· Vendor fix available
    Issue
    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a infinite loop caused by negative size vulnerability in ruby gem package tar header that can result in a negative size could cause an infinite loop.. This vulnerability appears to have been fixed in 2.7.6.

    Recommended action: Upgrade to 9.1.16.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  7. High, CVSS 7.5MavenPublished

    RubyGems Link Following vulnerability

    CVE-2018-1000073 · GHSA-gx69-6cp4-hxrj

    Affected
    • Maven org.jruby:jruby-stdlib < 9.1.16.0
    Fixed in
    9.1.16.0· Vendor fix available
    Issue
    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in installlocation function of package.rb that can result in path traversal when writing to a symlinked basedir outside of the root. This vulnerability appears to have been fixed in 2.7.6.

    Recommended action: Upgrade to 9.1.16.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →