Skip to content

← Public intelligence

Maven package

org.jolokia:jolokia-core

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.1MavenPublished

    Cross-Site Request Forgery in Jolokia

    CVE-2018-10899 · GHSA-xcxf-7q4p-cj26

    Affected
    • Maven org.jolokia:jolokia-core >= 1.2, < 1.6.1
    Fixed in
    1.6.1· Vendor fix available
    Issue
    A flaw was found in Jolokia versions from 1.2 to before 1.6.1. Affected versions are vulnerable to a system-wide CSRF. This holds true for properly configured instances with strict checking for origin and referrer headers. This could result in a Remote Code Execution attack.

    Recommended action: Upgrade to 1.6.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. UnratedMavenPublished

    Cross-Site Request Forgery in Jolokia

    CVE-2014-0168 · GHSA-fjhw-8222-g2hg

    Affected
    • Maven org.jolokia:jolokia-core < 1.2.1
    Fixed in
    1.2.1· Vendor fix available
    Issue
    Cross-site request forgery (CSRF) vulnerability in Jolokia before 1.2.1 allows remote attackers to hijack the authentication of users for requests that execute MBeans methods via a crafted web page.

    Recommended action: Upgrade to 1.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 6.1MavenPublished

    Cross-site Scripting in Jolokia agent

    CVE-2018-1000129 · GHSA-hfpg-gqjw-779m

    Affected
    • Maven org.jolokia:jolokia-core >= 1.3.7, < 1.5.0
    Fixed in
    1.5.0· Vendor fix available
    Issue
    An XSS vulnerability exists in the Jolokia agent version 1.3.7 in the HTTP servlet that allows an attacker to execute malicious javascript in the victim's browser.

    Recommended action: Upgrade to 1.5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 8.1MavenPublished

    Injection in Jolokia agent

    CVE-2018-1000130 · GHSA-rhqj-4pp8-vvgf

    Affected
    • Maven org.jolokia:jolokia-core >= 1.3.7, < 1.5.0
    Fixed in
    1.5.0· Vendor fix available
    Issue
    A JNDI Injection vulnerability exists in Jolokia agent version 1.3.7 in the proxy mode that allows a remote attacker to run arbitrary Java code on the server.

    Recommended action: Upgrade to 1.5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →