High, CVSS 7.5MavenPublished
Server-Side Request Forgery in Jodd HTTP
CVE-2022-29631 · GHSA-pp3c-cf6j-m3ff
- Affected
- Maven org.jodd:jodd-http >= 5.0.0, < 6.2.1
- Fixed in
- 6.2.1· Vendor fix available
- Issue
- Jodd HTTP v6.0.9 was discovered to contain multiple CLRF injection vulnerabilities via the components jodd.http.HttpRequest#set and jodd.http.HttpRequest#send. These vulnerabilities allow attackers to execute Server-Side Request Forgery (SSRF) via a crafted TCP payload.
Recommended action: Upgrade to 6.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.