Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins.workflow:workflow-support

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.0MavenPublished

    Stored XSS vulnerability in Jenkins Pipeline: Supporting APIs Plugin

    CVE-2022-43409 · GHSA-64r9-x74q-wxmh

    Affected
    • Maven org.jenkins-ci.plugins.workflow:workflow-support < 839.v35e2736cfd5c
    Fixed in
    839.v35e2736cfd5c· Vendor fix available
    Issue
    Pipeline: Supporting APIs Plugin provides a feature to add hyperlinks, that send POST requests when clicked, to build logs. These links are used by Pipeline: Input Step Plugin to allow users to proceed or abort the build, or by Pipeline: Job Plugin to allow users to forcibly terminate the build after aborting it. Pipeline: Supporting APIs Plugin 838.va3a087b4055b and earlier does not sanitize or properly encode URLs of these hyperlinks in build logs. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to create Pipelines. Pipeline: Supporting APIs Plugin 839.v35e2736cfd5c properly encodes URLs of these hyperlinks in build logs.

    Recommended action: Upgrade to 839.v35e2736cfd5c or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 8.8MavenPublished

    Arbitrary code execution due to incomplete sandbox protection in Pipeline: Supporting APIs Plugin

    CVE-2018-1000058 · GHSA-p3g4-9xfv-wq9v

    Affected
    • Maven org.jenkins-ci.plugins.workflow:workflow-support <= 2.17
    Fixed in
    2.18· Vendor fix available
    Issue
    Jenkins Pipeline: Supporting APIs Plugin 2.17 and earlier have an arbitrary code execution due to incomplete sandbox protection: Methods related to Java deserialization like readResolve implemented in Pipeline scripts were not subject to sandbox protection, and could therefore execute arbitrary code. This could be exploited e.g. by regular Jenkins users with the permission to configure Pipelines in Jenkins, or by trusted committers to repositories containing Jenkinsfiles.

    Recommended action: Upgrade to 2.18 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →