Medium, CVSS 6.1MavenPublished
Reflected XSS vulnerability in Jenkins VncViewer Plugin
CVE-2020-2207 · GHSA-2j4h-cjgh-659v
- Affected
- Maven org.jenkins-ci.plugins:vncviewer <= 1.7
- Fixed in
- 1.8· Vendor fix available
- Issue
- VncViewer Plugin 1.7 and earlier does not escape a parameter value in the checkVncServ form validation endpoint output. This results in a reflected cross-site scripting (XSS) vulnerability. VncViewer Plugin 1.8 escapes the parameter value in the output.
Recommended action: Upgrade to 1.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.