Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:vncrecorder

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1MavenPublished

    Reflected XSS vulnerability in Jenkins VncRecorder Plugin

    CVE-2020-2206 · GHSA-fq52-6cjf-jw59

    Affected
    • Maven org.jenkins-ci.plugins:vncrecorder <= 1.25
    Fixed in
    1.35· Vendor fix available
    Issue
    VncRecorder Plugin 1.25 and earlier does not escape a parameter value in the checkVncServ form validation endpoint output. This results in a reflected cross-site scripting (XSS) vulnerability. VncRecorder Plugin 1.35 escapes the parameter value in the output.

    Recommended action: Upgrade to 1.35 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 4.8MavenPublished

    Stored XSS vulnerability in Jenkins VncRecorder Plugin

    CVE-2020-2205 · GHSA-vqp8-h53h-3jfh

    Affected
    • Maven org.jenkins-ci.plugins:vncrecorder <= 1.25
    Fixed in
    1.35· Vendor fix available
    Issue
    VncRecorder Plugin 1.25 and earlier does not escape a tool path in the checkVncServ form validation endpoint accessed e.g. via job configuration forms. This results in a stored cross-site scripting (XSS) vulnerability exploitable by Jenkins administrators. VncRecorder Plugin 1.35 escapes the tool path.

    Recommended action: Upgrade to 1.35 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →