Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:violations

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1MavenPublished

    Jenkins Violation Plugin allows Cross-Site Scripting (XSS)

    CVE-2012-4440 · GHSA-5qpv-27q3-6484

    Affected
    • Maven org.jenkins-ci.plugins:violations < 0.7.11
    Fixed in
    0.7.11· Vendor fix available
    Issue
    Cross-site Scripting (XSS) in Jenkins main before 1.482 and LTS before 1.466.2 allows remote attackers to inject arbitrary web script or HTML in the Violations plugin.

    Recommended action: Upgrade to 0.7.11 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →