High, CVSS 8.0MavenPublished
Stored XSS vulnerability in Validating String Parameter Plugin
CVE-2020-2257 · GHSA-fvwh-wv43-8qj5
- Affected
- Maven org.jenkins-ci.plugins:validating-string-parameter <= 2.4
- Fixed in
- 2.5· Vendor fix available
- Issue
- Validating String Parameter Plugin 2.4 and earlier does not escape regular expressions in tooltips. Additionally, Validating String Parameter Plugin 2.4 does not escape parameter names and parameter descriptions. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Job/Configure permission. Validating String Parameter Plugin 2.5 escapes regular expressions in tooltips and parameter names. Parameter descriptions are rendered using the configured markup formatter.
Recommended action: Upgrade to 2.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.