Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:synopsys-coverity

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.3MavenPublished

    CSRF vulnerability in Jenkins Coverity Plugin allow capturing credentials

    CVE-2023-23848 · GHSA-c3v2-5388-v8pw

    Affected
    • Maven org.jenkins-ci.plugins:synopsys-coverity <= 3.0.2
    Fixed in
    3.0.3· Vendor fix available
    Issue
    Missing permission checks in Synopsys Jenkins Coverity Plugin 3.0.2 and earlier allow attackers with Overall/Read permission to connect to an attacker-specified HTTP server using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.

    Recommended action: Upgrade to 3.0.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Low, CVSS 3.5MavenPublished

    CSRF vulnerability in Synopsys Jenkins Coverity Plugin

    CVE-2023-23847 · GHSA-px6v-6jhf-j46r

    Affected
    • Maven org.jenkins-ci.plugins:synopsys-coverity <= 3.0.2
    Fixed in
    3.0.3· Vendor fix available
    Issue
    A cross-site request forgery (CSRF) vulnerability in Synopsys Jenkins Coverity Plugin 3.0.2 and earlier allows attackers to connect to an attacker-specified HTTP server using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.

    Recommended action: Upgrade to 3.0.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 4.3MavenPublished

    Synopsys Jenkins Coverity Plugin has Incorrect Default Permissions

    CVE-2023-23850 · GHSA-jwr6-75xh-jh5j

    Affected
    • Maven org.jenkins-ci.plugins:synopsys-coverity < 3.0.3
    Fixed in
    3.0.3· Vendor fix available
    Issue
    Synopsys Coverity Plugin 3.0.2 and earlier does not perform permission checks in several HTTP endpoints. This allows attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins. Those can be used as part of an attack to capture the credentials using another vulnerability. An enumeration of credentials IDs in Synopsys Coverity Plugin 3.0.3 requires the appropriate permissions.

    Recommended action: Upgrade to 3.0.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →