Medium, CVSS 5.4MavenPublished
Stored XSS vulnerability in Jenkins Sonargraph Integration Plugin
CVE-2020-2201 · GHSA-f799-hfg3-48jp
- Affected
- Maven org.jenkins-ci.plugins:sonargraph-integration <= 3.0.0
- Fixed in
- 3.0.1· Vendor fix available
- Issue
- Sonargraph Integration Plugin 3.0.0 and earlier does not escape the file path for the Log file field form validation. This results in a stored cross-site scripting (XSS) vulnerability that can be exploited by users with Job/Configure permission. Sonargraph Integration Plugin 3.0.1 escapes the affected part of the error message.
Recommended action: Upgrade to 3.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.