High, CVSS 7.8MavenPublished
Jenkins SonarQube Scanner Plugin stored server authentication token in plain text
CVE-2018-1000425 · GHSA-3ccq-gccx-pm7j
- Affected
- Maven org.jenkins-ci.plugins:sonar <= 2.8
- Fixed in
- 2.8.1· Vendor fix available
- Issue
- An insufficiently protected credentials vulnerability exists in Jenkins SonarQube Scanner Plugin 2.8 and earlier in SonarInstallation.java that allows attackers with local file system access to obtain the credentials used to connect to SonarQube.
Recommended action: Upgrade to 2.8.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.