Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:rocketchatnotifier

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.3MavenPublished

    CSRF vulnerability in Jenkins RocketChat Notifier Plugin

    CVE-2022-28138 · GHSA-x25h-f84x-wh4m

    Affected
    • Maven org.jenkins-ci.plugins:rocketchatnotifier < 1.5.0
    Fixed in
    1.5.0· Vendor fix available
    Issue
    Jenkins RocketChat Notifier Plugin 1.4.10 and earlier does not perform a permission check in a method implementing form validation. This allows attackers with Overall/Read permission to connect to an attacker-specified URL using attacker-specified credential. Additionally, this form validation method does not require POST requests, resulting in a cross-site request forgery (CSRF) vulnerability. RocketChat Notifier Plugin 1.5.0 requires POST requests and Overall/Administer permission for the affected form validation method.

    Recommended action: Upgrade to 1.5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 4.3MavenPublished

    Missing permission check in Jenkins RocketChat Notifier Plugin

    CVE-2022-28139 · GHSA-4p8f-2fwv-6xcw

    Affected
    • Maven org.jenkins-ci.plugins:rocketchatnotifier < 1.5.0
    Fixed in
    1.5.0· Vendor fix available
    Issue
    Jenkins RocketChat Notifier Plugin 1.4.10 and earlier does not perform a permission check in a method implementing form validation. This allows attackers with Overall/Read permission to connect to an attacker-specified URL using attacker-specified credentials. Additionally, this form validation method does not require POST requests, resulting in a cross-site request forgery (CSRF) vulnerability. RocketChat Notifier Plugin 1.5.0 requires POST requests and Overall/Administer permission for the affected form validation method.

    Recommended action: Upgrade to 1.5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →