Skip to content

← Public intelligence

Maven package

org.jenkins-ci.plugins:resource-disposer

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Low, CVSS 3.1MavenPublished

    Jenkins Resource Disposer Plugin allows attacker to stop tracking specified resource

    CVE-2018-1999037 · GHSA-63jg-5wv6-7ghv

    Affected
    • Maven org.jenkins-ci.plugins:resource-disposer <= 0.11
    Fixed in
    0.12· Vendor fix available
    Issue
    A data modification vulnerability exists in Jenkins Resource Disposer Plugin 0.11 and earlier in AsyncResourceDisposer.java that allows attackers to stop tracking a specified resource. Additionally, this API endpoint did not require POST requests, resulting in a CSRF vulnerability. As of version 0.12, this API endpoint requires POST requests and Overall/Administer permissions.

    Recommended action: Upgrade to 0.12 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →